MyTitan Update

Incident Report for Titan Business Intelligence

Resolved

The MyTitan update has been released successfully. Hope you enjoy the new features.

regards
The TitanBI team
Posted Feb 20, 2025 - 10:49 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 19, 2025 - 18:20 GMT

Investigating

Hi All,
We are releasing a new version of our MyTitan Live Sales App over the coming hours. This will be available in the Apple iOS Store and the Android Play Store once it has gone through their approval process. Your existing MyTitan App may update automatically depending on your device setting or you can manually initiate the update.
Please note: If you should have any operational issues after the update please uninstall the MyTitan app and then reinstall the MyTitan App from your app store.

New Features included in the release are:
1. Live Open Table Analysis Report (display of items ordered on the table by touching the table number).
2. Live Operator Turnover Report.
3. Live terminal Turnover Report.
4. MyTitan Performance Enhancements.
5. Enhancements in Dark/Light mode operation on devices.
Posted Feb 19, 2025 - 18:18 GMT
This incident affected: Titan (MyTitan).