Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 23, 2025 - 10:45 IST
Scheduled
We are scheduling a software release @11am today for 1hr. The Titan platform will be offline until 12:00.
You may experience issues with the Titan platform during this planned release. After the Planned maintenance has been completed, please ensure to press the Shift Key and the F5 Key at the same time after logging into TitanBI. This will reload any script updates that are required.
We will keep you updated in due course.
Titan Support Team
Posted Sep 23, 2025 - 10:44 IST
This scheduled maintenance affected: Titan (TitanBI Website, MyTitan, MyStockBuddy), MyFlipdish (Online Ordering), MyDojo (Credit Card Payment Platform), and Microsoft Azure (Azure Virtual Machine, Azure SQL Database, Azure Functions).