Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 30, 2026 - 11:00 BST
Scheduled
Vat Rate Changes are occuring in the Uk & Ireland which will have an impact on your business:
As announced by the UK Government, from 25 June 2026 to 1 September 2026, VAT on eligible children's meals will be reduced from 20% to 5%.
As announced by the Irish Government, a VAT rate change from 13.5% to 9% on Food and Hairdressing will come into operation on the 1st of July 2026.
Please update the new VAT rates in Titan for the relevant taxation regions. Please create the new Vat rate if it does not exist and change the VAT rate for each Department and Sub Product Category as follows:
1. Go to System Maintenance → Company → Vat Rate Create the new Vate Rate if it does not already exisits and save changes. 2. Go to System Maintenance → Company → Sub Product Category Open each Sub Product Category. In the VAT Rate section, select the new VAT rate and save the changes. 2. Go to System Maintenance → Branch → Department Open each Department. In the VAT Rate section, select the new VAT rate and save the changes. 3. Run a Titan Sync. 4. Publish the program changes to the Tills from Commander.
Posted Jun 30, 2026 - 10:22 BST
This scheduled maintenance affects: Titan (TitanBI Website, MyTitan).